Hướng dẫn sử dụng giao diện dòng lệnh cơ bản của Cisco Phần 1

Tìm hiểu tập lệnh thông số kỹ thuật Cisco IOS cơ bản

Như những bạn cũng biết giao diện dòng lệnh của Cisco IOS (CLI) là giao diện người dùng chính được sử dụng để định cấu hình, giám sát và bảo dưỡng những thiết bị mạng của Cisco.

Giao diện người dùng này được được được được được cho phép bạn thực thi trực tiếp và đơn thuần những lệnh Cisco IOS, cho dù sử dụng bảng điều khiển bộ định tuyến hoặc thiết bị đầu cuối hoặc sử dụng những phương pháp truy vấn từ xa.

Ở phần nội dung này chúng tôi sẽ miêu tả những tính năng cơ bản của Cisco IOS CLI và cách sử dụng chúng một cách hiệu quả nhất. Các chủ đề được đề cập tới sẽ gồm có ra mắt về những chính sách lệnh của Cisco IOS, những tính năng điều hướng và chỉnh sửa, những tính năng trợ giúp và những tính năng tìm kiếm lịch sử dòng lệnh.

Chúng ta sẽ khởi đầu tìm hiểu và khám phá chi tiết cụ thể những lệnh cơ bản thông số kỹ thuật trên Cisco IOS.

Tổng quan về những chính sách lệnh của Cisco IOS XE CLI

Để tương hỗ thông số kỹ thuật những thiết bị của Cisco, giao diện dòng lệnh của Cisco IOS XE được chia thành những chính sách lệnh khác nhau. Mỗi chính sách lệnh có một bộ lệnh riêng có sẵn để cấu hình, bảo dưỡng và giám sát những hoạt động của bộ định tuyến và mạng.

Các lệnh đều có sẵn và nếu bạn gặp khó khăn vất vả hoàn toàn hoàn toàn hoàn toàn hoàn toàn hoàn toàn hoàn toàn hoàn toàn hoàn toàn hoàn toàn hoàn toàn có thể nhập dấu chấm hỏi ( ? ) chúng sẽ cho phép bạn có được list những lệnh có sẵn cho mỗi chính sách lệnh mà bạn cần. Việc sử dụng những lệnh đơn cử cho phép bạn điều hướng từ chính sách lệnh này sang chính sách lệnh khác.

Khi bạn khởi đầu một phiên trên bộ định tuyến, bạn thường mở màn ở chính sách EXEC của người dùng, đây là một trong hai cấp truy vấn của chính sách EXEC. Đối với mục tiêu bảo mật, chỉ có một tập hợp con giới hạn của những lệnh EXEC có sẵn trong chính sách EXEC của người dùng. Mức truy vấn này được dành riêng cho những tác vụ không biến hóa thông số kỹ thuật của bộ định tuyến, chẳng hạn như xác lập trạng thái bộ định tuyến.

Để có quyền truy vấn vào tổng thể những lệnh, bạn phải vào chính sách EXEC độc quyền, đây là cấp truy vấn thứ hai cho chính sách EXEC. Thông thường, bạn phải nhập mật khẩu để vào chính sách EXEC đặc quyền. Trong chính sách EXEC đặc quyền, bạn có thể nhập bất kể lệnh EXEC nào, vì chính sách EXEC độc quyền là siêu bộ của những lệnh chính sách EXEC của người dùng.

Hầu hết những lệnh chính sách EXEC là những lệnh một lần, chẳng hạn như những lệnh show hoặc nhiều hơn, hiển thị trạng thái thông số kỹ thuật hiện tại và những lệnh xóa, giúp xóa những bộ đếm hoặc giao diện. Các lệnh chính sách EXEC không được lưu trong quy trình khởi động lại bộ định tuyến.

Từ chính sách EXEC đặc quyền, bạn có thể vào chính sách thông số kỹ thuật toàn bộ trên thiết bị. Trong chính sách này, bạn có thể nhập những lệnh thông số kỹ thuật những đặc điểm chung của hệ thống.

Bạn cũng có thể sử dụng chính sách thông số kỹ thuật này để vào những chính sách thông số kỹ thuật cụ thể. Các chính sách cấu hình, gồm có chính sách thông số kỹ thuật đặc quyền, cho phép bạn đổi khác thông số kỹ thuật đang chạy. Nếu sau này bạn lưu cấu hình, những lệnh này được lưu trữ trên bộ khởi động lại bộ định tuyến.

Từ chính sách thông số kỹ thuật toàn cầu, bạn có thể nhập nhiều chế độ thông số kỹ thuật dành riêng cho giao thức hoặc tính năng cụ thể. Hệ thống phân cấp CLI nhu yếu bạn chỉ nhập những chế độ cấu hình đơn cử này trải qua chế độ cấu hình đặc quyền.

Chế độ giám sát ROM là chế độ riêng được sử dụng khi bộ định tuyến không thể khởi động đúng cách. Nếu mạng lưới mạng lưới mạng lưới mạng lưới hệ thống của bạn (bộ định tuyến, chuyển đổi hoặc sever truy cập) không tìm thấy hình ảnh hệ thống hợp lệ để tải khi khởi động, hệ thống sẽ vào chế độ giám sát ROM.

Chế độ giám sát ROM (ROMMON) cũng có thể được truy vấn bằng cách làm gián đoạn trình tự khởi động trong khi khởi động.

Danh sách những tác vụ Cisco IOS XE CLI

Để làm quen với những tính năng của Cisco IOS XE CLI, hãy thực hiện bất kể tác vụ được nêu ra bên dưới đây.

Getting Context-Sensitive Help

Using the no and default Forms of Commands

Using Command History

Using CLI Editing Features and Shortcuts

Searching and Filtering CLI Output

Sử dụng tìm kiếm những câu lệnh trên thiết bị

Nhập một dấu hỏi ( ? ) Tại dấu nhắc hệ thống sẽ hiển thị list những lệnh có sẵn cho mỗi chế độ lệnh. Bạn cũng có thể nhận được một list những đối số và từ khóa có sẵn cho bất kể lệnh nào với tính năng trợ giúp theo ngữ cảnh.

Để nhận trợ giúp đơn cử cho chế độ lệnh, tên lệnh, từ khóa hoặc đối số, hãy sử dụng bất kỳ lệnh nào sau đây:

Câu lệnh
Mô tả

(prompt
Hiển thị một diễn đạt ngắn gọn về hệ thống trợ giúp.

)# help

(prompt
Liệt kê những lệnh trong chế độ hiện tại mở màn bằng một chuỗi ký tự cụ thể.

)#

abbreviated-command-entry?

(prompt
Hoàn thành một tên lệnh một phần.

)# abbreviated-command-entry

(prompt
Liệt kê tất cả những lệnh có sẵn trong chế độ lệnh.

)# ?

(prompt
Liệt kê những tùy chọn cú pháp có sẵn (đối số và từ khóa) cho lệnh.

)# command?

(prompt
Liệt kê những tùy chọn cú pháp có sẵn tiếp theo cho lệnh.

)# command

keyword ?

Bảng: Tìm kiếm list lệnh trên thiết bị

– Lưu ý rằng lời nhắc hệ thống sẽ thay đổi tùy thuộc vào chế độ cấu hình bạn đang ở.

Để có được danh sách những lệnh khởi đầu bằng một chuỗi ký tự cụ thể, hãy nhập những ký tự đó theo sau bằng dấu chấm hỏi ( ? ).

Bạn có thể viết tắt các lệnh và từ khóa theo số lượng ký tự cho phép viết tắt duy nhất. Ví dụ, bạn có thể viết tắt lệnh configure terminal để config t. Vì dạng viết tắt của lệnh là duy nhất, bộ định tuyến sẽ chấp nhận dạng viết tắt và thực thi lệnh.

Router#

help

Help may be requested at any point in a command by entering

a question mark ‘?’. If nothing matches, the help list will

be empty and you must back up until entering a ‘?’ shows the

available options.

Two styles of help are provided:

1. Full help is available when you are ready to enter a

command argument (e.g. ‘show ?’) and describes each possible

argument.

2. Partial help is provided when an abbreviated argument is entered

and you want to know what arguments match the input

(e.g. ‘show pr?’.)

Như được miêu tả trong đầu ra lệnh trợ giúp, bạn có thể sử dụng dấu hỏi ( ? ) Để triển khai xong xong xong tên lệnh một phần (trợ giúp một phần) hoặc để có được danh sách các đối số hoặc từ khóa sẽ hoàn thành lệnh hiện tại.

– Ví dụ sau minh họa cách tính năng trợ giúp theo ngữ cảnh cho phép bạn tạo danh sách truy vấn từ chế độ cấu hình.

Nhập các vần âm co tại dấu nhắc hệ thống theo sau là một dấu hỏi ( ? ). Đừng chừa một khoảng chừng chừng chừng chừng trống giữa vần âm cuối cùng vàdấu chấm hỏi. Hệ thống cung ứng các lệnh bắt đầu bằng co .

Router# co?

configure connect copy

Nhập lệnh configure theo sau là khoảng trắng và dấu hỏi để liệt kê các từ khóa cho lệnh và lý giải ngắn gọn:

Router# configure ?

memory Configure from NV memory

network Configure from a TFTP network host

overwrite-network Overwrite NV memory from TFTP network host

terminal Configure from the terminal

Nhập lệnh configure terminal để vào chế độ cấu hình đặc quyền:

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#

CLI phân phối cách ly lỗi dưới dạng chỉ báo lỗi, ký hiệu dấu mũ (^). Biểu tượng ^ Open tại điểm trong chuỗi lệnh nơi người dùng đã nhập cú pháp lệnh không đúng mực hoặc không được nhận dạng. Ví dụ, biểu tượng dấu mũ trong đầu ra sau đây cho thấy vần âm bị nhập sai trong lệnh:

Router# configure terminal

^

% Invalid input detected at ‘^’ marker.

Router#

Lưu ý rằng một thông báo lỗi (được biểu thị bằng ký hiệu%) xuất hiện trên màn hình để cảnh báo bạn về điểm ghi lại lỗi.

Nhập lệnh access-list theo sau là khoảng trắng và dấu hỏi để liệt kê các tùy chọn khả dụng cho lệnh:

Router(config)# access-list ?

<1-99> IP standard access list

<100-199> IP extended access list

<1100-1199> Extended 48-bit MAC address access list

<1300-1999> IP standard access list (expanded range)

<200-299> Protocol type-code access list

<2000-2699> IP extended access list (expanded range)

<700-799> 48-bit MAC address access list

dynamic-extended Extend the dynamic ACL absolute timer

rate-limit Simple rate-limit specific access list

Hai số trong ngoặc vuông biểu thị một phạm vi bao gồm. Nhập danh sách truy cập số 99 và sau đó nhập một dấu hỏi khác để xem các đối số vận dụng cho từ khóa và lý giải ngắn gọn:

Router(config)# access-list 99 ?

deny Specify packets to reject

permit Specify packets to forward

Nhập đối số phủ nhận theo sau là dấu chấm hỏi ( ? )để liệt kê các tùy chọn bổ sung:

Router(config)# access-list 99 deny ?

A.B.C.D Address to match

Nói chung, chữ in hoa đại diện thay mặt cho các biến (đối số). Nhập địa chỉ IP theo sau là một dấu hỏi ( ? ) Để liệt kê các tùy chọn bổ sung:

Router(config)# access-list 99 deny 172.31.134.0 ?

A.B.C.D Mask of bits to ignore

Hầu như mọi lệnh cấu hình đều không có dạng. Sử dụng lệnh mà không có từ khóa để kích hoạt một tính năng bị vô hiệu hoặc để bật một tính năng bị tắt theo mặc định.

Ví dụ: Định tuyến IP được bật theo mặc định. Để vô hiệu hóa định tuyến IP, sử dụng hình thức định tuyến không có ip của lệnh định tuyến ip. Để kích hoạt nó, sử dụng mẫu định tuyến ip đơn thuần. Các ấn phẩm tìm hiểu thêm lệnh ứng dụng Cisco IOS miêu tả tính năng của dạng không có lệnh bất cứ khi nào.

Nhiều lệnh CLI cũng có dạng mặc định. Bằng cách phát hành lệnh tên lệnh mặc định, bạn có thể định cấu hình lệnh thành thiết lập mặc định. Các tài liệu tham chiếu lệnh phần mềm Cisco IOS thường mô tả công dụng của dạng mặc định của lệnh khi biểu mẫu mặc định thực hiện một chức năng khác với dạng đơn giản và không có dạng lệnh nào.

Sử dụng các ví dụ về Cisco IOS XE CLI

CLI cung ứng cách ly lỗi dưới dạng chỉ báo lỗi, ký hiệu dấu mũ (^). Biểu tượng ^ xuất hiện tại điểm trong chuỗi lệnh nơi bạn đã nhập sai lệnh, từ khóa hoặc đối số.

Trong ví dụ sau, giả sử bạn muốn đặt đồng hồ. Sử dụng trợ giúp theo ngữ cảnh để xác định cú pháp lệnh chính xác để đặt đồng hồ.

Router# clock ?

set Set the time and date

Router# clock

Đầu ra trợ giúp cho thấy rằng từ khóa được thiết lập là bắt buộc. Xác định cú pháp để nhập thời gian:

Router# clock set ?

hh:mm:ss Current time

Router# clock set

Enter the current time:

Router# clock set 13:32:00

% Incomplete command.

Hệ thống chỉ ra rằng bạn cần cung cấp các đối số bổ trợ để hoàn thành lệnh. Nhấn Ctrl-P hoặc Mũi tên Lên để tự động hóa lặp lại mục nhập lệnh trước đó. Sau đó thêm dấu cách và dấu chấm hỏi ( ? ) Để hiển thị các đối số bổ sung:

Router# clock set 13:32:00 ?

<1-31> Day of the month

MONTH Month of the year

Bây giờ bạn có thể hoàn thành mục nhập lệnh:

Router# clock set 13:32:00 February 01

^

% Invalid input detected at ‘^’ marker.

Biểu tượng dấu mũ (^) và phản hồi trợ giúp chỉ ra lỗi tại 01. Để liệt kê đúng cú pháp, hãy nhập lệnh đến điểm xảy ra lỗi và sau đó nhập dấu hỏi ( ? ):

Router# clock set 13:32:00 February ?

<1-31> Day of the month

Router# clock set 13:32:00 February 23 ?

<1993-2035> Year

Tìm kiếm và lọc ví dụ đầu ra CLI

Sau đây là đầu ra mẫu một phần từ nhiều nvram: startup-config | bắt đầu lệnh chế độ EXEC độc quyền bắt đầu đầu ra chưa được lọc với dòng tiên phong chứa ip biểu thức chính quy. Tại dấu nhắc –More–, người dùng chỉ định bộ lọc để loại trừ các dòng đầu ra có chứa ip biểu thức chính quy.

Router# more nvram:startup-config | begin ip

address-family ipv4

exit-address-family

!

address-family ipv6

exit-address-family

!

security passwords min-length 1

!

no aaa new-model

ip subnet-zero

no ip domain lookup

ip host sjc-tftp02 171.69.17.17

ip host sjc-tftp01 171.69.17.19

ip host dirt 171.69.1.129

!

!

multilink bundle-name authenticated

!

!

redundancy

mode sso

!

!

bba-group pppoe global

!

!

interface GigabitEthernet0/0/0

ip address 10.4.9.158 255.255.255.0

media-type rj45

speed 1000

duplex full

negotiation auto

no cdp enable

!

interface GigabitEthernet0/0/1

no ip address

media-type rj45

speed 1000

duplex full

negotiation auto

no cdp enable

!

interface POS0/1/0

no ip address

shutdown

no cdp enable

!

interface POS0/1/1

no ip address

shutdown

no cdp enable

!

interface GigabitEthernet0

vrf forwarding Mgmt-intf

no ip address

speed 1000

duplex full

negotiation auto

!

ip default-gateway 10.4.9.1

ip classless

ip default-network 0.0.0.0

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0

ip route 171.69.0.0 255.255.0.0 10.4.9.1

!

no ip http server

no ip http secure-server

!

!

snmp mib bulkstat schema E0

snmp mib bulkstat schema IFMIB

snmp mib bulkstat transfer 23

snmp mib bulkstat transfer bulkstat1

!

!

control-plane

!

!

line con 0

exec-timeout 30 0

logging synchronous

stopbits 1

line aux 0

stopbits 1

line vty 0 4

privilege level 15

password lab

login

!

End

Sau đây là mẫu đầu ra một phần của hơn nvram: startup-config | gồm có lệnh EXEC đặc quyền. Nó chỉ hiển thị các dòng có chứa ip biểu thức chính quy.

Router# more nvram:startup-config | include ip

ip subnet-zero

ip domain-name cisco.com

ip name-server 1192.168.48.48

ip name-server 172.16.2.132

Sau đây là đầu ra mẫu một phần từ nhiều nvram: startup-config | loại trừ lệnh EXEC đặc quyền. Nó loại trừ các dòng có chứa dịch vụ biểu thức chính quy. Tại dấu nhắc –More–, người dùng chỉ định bộ lọc với Dialer1 biểu thức chính quy. Chỉ định bộ lọc này liên tục đầu ra với dòng tiên phong chứa Dialer1

Router# more nvram:startup-config | exclude service

!

version 12.2

!

hostname router

!

boot system flash

no logging buffered

!

ip subnet-zero

ip domain-name cisco.com

.

.

.

–More–

/Dialer1

filtering…

interface Dialer1

no ip address

no ip directed-broadcast

dialer in-band

no cdp enable

Sau đây là mẫu đầu ra một phần từ các chương trình giao diện EXEC người dùng hoặc chế độ lệnh Privileged EXEC với một tìm kiếm đầu ra quy định. Việc sử dụng các từ khóa bắt đầu Fast Ethernet sau khi đường ống bắt đầu đầu ra chưa được lọc với dòng tiên phong chứa Fast Ethernet biểu thức thông thường. Tại dấu nhắc –More–, người dùng chỉ định bộ lọc chỉ hiển thị các dòng có chứa Biểu thức chính quy tiếp nối đuôi nhau .

Router# show interface | begin FastEthernet

FastEthernet0/0 is up, line protocol is up

Hardware is Lance, address is 0060.837c.6399 (bia 0060.837c.6399)

Description: ip address is 172.1.2.14 255.255.255.0

Internet address is 172.1.2.14/24

.

.

.

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

–More–

+Serial

filtering…

Serial1 is up, line protocol is up

Serial2 is up, line protocol is up

Serial3 is up, line protocol is down

Serial4 is down, line protocol is down

Serial5 is up, line protocol is up

Serial6 is up, line protocol is up

Serial7 is up, line protocol is up

Sau đây là đầu ra mẫu một phần từ bộ đệm hiển thị | loại trừ lệnh. Nó loại trừ các dòng có chứa biểu thức chính quy 0 bỏ lỡ. Tại dấu nhắc –More–, người dùng chỉ định tìm kiếm liên tục đầu ra được lọc bắt đầu bằng dòng đầu tiên có chứa Serial0.

Router# show buffers | exclude 0 misses

Buffer elements:

398 in không lấy phí list (500 max allowed)

Public buffer pools:

Small buffers, 104 bytes (total 50, permanent 50):

50 in không lấy phí list (20 min, 150 max allowed)

551 hits, 3 misses, 0 trims, 0 created

Big buffers, 1524 bytes (total 50, permanent 50):

49 in không lấy phí list (5 min, 150 max allowed)

Very Big buffers, 4520 bytes (total 10, permanent 10):

.

.

.

Huge buffers, 18024 bytes (total 0 permanent 0):

0 in free list (0 min, 4 max allowed)

–More–

/Serial0

filtering…

Serial0 buffers, 1543 bytes (total 64, permanent 64):

16 in free list (0 min, 64 max allowed)

48 hits, 0 fallbacks

Sau đây là đầu ra mẫu một phần từ giao diện hiển thị | gồm có người dùng EXEC hoặc chế độ lệnh EXEC đặc quyền. Việc sử dụng các từ khóa bao gồm ( is ) sau ống (|) làm cho lệnh chỉ hiển thị các dòng có chứa biểu thức chính quy (is). Dấu ngoặc buộc bao gồm các khoảng trắng trước và sau là. Việc sử dụng dấu ngoặc đơn bảo vệ rằng chỉ các dòng có chứa một khoảng trắng cả trước và sau nó sẽ được đưa vào đầu ra (ví dụ: không bao gồm từ tìm kiếm, ví dụ như các từ như cách ngắt liên kết ).

router# show interface | include ( is )

ATM0 is administratively down, line protocol is down

Hardware is ATMizer BX-50

Dialer0/1 is up (spoofing), line protocol is up (spoofing)

Hardware is Unknown

DTR is pulsed for 1 seconds on reset

FastEthernet0/0 is up, line protocol is up

Hardware is Lance, address is 0060.837c.6399 (bia 0060.837c.6399)

Internet address is 172.21.53.199/24

FastEthernet0/1 is up, line protocol is up

Hardware is Lance, address is 0060.837c.639c (bia 0060.837c.639c)

Internet address is 10.5.5.99/24

Serial0:0 is down, line protocol is down

Hardware is DSX1

.

.

.

–More—

Tại dấu nhắc –More–, người dùng chỉ định tìm kiếm liên tục đầu ra được lọc bắt đầu bằng dòng đầu tiên có chứa Serial0: 13:

/Serial0:13

filtering…

Serial0:13 is down, line protocol is down

Hardware is DSX1

Internet address is 10.0.0.2/8

0 output errors, 0 collisions, 2 interface resets

Timeslot(s) Used:14, Transmitter delay is 0 flag

Tập lệnh EXEC trong cấu hình

Phiên bản Cisco IOS Release 12.1 đã cung cấp cho khung thao tác nhiều tập lệnh khác nhau như Show, Clear, debug và tất yếu bạn cũng có thể nhập trong bất kỳ chế độ cấu hình nào bằng cách sử dụng lệnh EXEC mong muốn.

Tính năng này cung cấp sự tiện lợi khi nhập các lệnh cấp EXEC mà không cần thoát khỏi chế độ cấu hình hiện tại.

Tất nhiên, để thực thi lệnh cấp EXEC trong bất kỳ chế độ cấu hình nào (bao gồm các cấu hình nhánh ) hãy bảo vệ rằng bạn đã làm những tác vụ như dưới đây:

– Enable

– Configure terminal

– Do command

Command or Action
Purpose

Step 1
enable
Enables privileged EXEC mode.

Enter your password if prompted.

Example:

Router> enable

Step 2
configure terminal
Enters global configuration mode.

Example:

Router# configure terminal

Step 3
do command
Allows you to execute any EXEC mode command from within any configuration mode.

command –The EXEC command to be executed.

Example:

Router(config)# configuration command

Bảng: Chi tiết các bước thực hiện

Sử dụng câu lệnh cho cấu hình giao diện (Interface Configuration)

Để thực thi lệnh cấp EXEC cho giao diện cụ thể trên bộ định tuyến, bạn hãy hoàn thành tác vụ trong phần này:

– Enable

– Configure terminal

– Interface type slot iport

– Do command

Command or Action
Purpose

Step 1
enable
Enables privileged EXEC mode.

Enter your password if prompted.

Example:

Router> enable

Step 2
configure terminal
Enters global configuration mode.

Example:

Router# configure terminal

Step 3
interface type slot /port
The syntax for this command varies according to your platform and Cisco IOS release.
For complete information, refer to the “Additional References” section.

The slot/port argument identifies the slot and port on the router where you are
entering docommands.

Example:

Router(config)# interface serial 3/0

Step 4
do command
Allows you to execute any EXEC mode command from within any configuration mode
on a specific interface.

command –The EXEC command to be executed.

Example:

Router(config-if)# do show interfaces serial 3/0

Dưới đây là 1 số ít những ví dụ cụ thể cho các lệnh EXEC trong chế độ cấu hình, bạn có thể tham khảo và áp dụng

Cấu hình giao diện (Show interface Command)

Ví dụ sử dụng với tập lệnh showinterface trong cấu hình.

Router(config)# do show interfaces serial 3/0

Serial3/0 is up, line protocol is up

Hardware is M8T-RS232

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

Last input never, output 1d17h, output hang never

Last clearing of “show interface” counters never

.

.

Hay như trong ví dụ về câu lệnh Clear vpdn dưới đây.

Router(config-vpdn)# do clear vpdn tunnel

Router(config-vpdn)#

Trên đây là phần một giới thiệu tổng quan về tập lệnh cấu hình cơ bản trên IOS Cisco, ở những phần tiếp theo chúng tôi sẽ tiếp tục gửi tới quý khách hàng nhiều hơn những thông tin. Hãy theo dói nhé! Đừng quên liên hệ với chúng tôi 0383470263 nếu bạn cần tư vấn tương hỗ chi tiết hơn về sản phẩm.